Zimbra: Corrigindo o erro “Object with that ID Already Exists”

photo

Olá ! Nesse artigo gostaria de compartilhar com vocês um script para correção do erro “Object with that ID Already Exists” na base de dados do Zimbra.

Somente para relato, no meu caso, esse erro foi apresentado após a restauração das bases de dados, mas pode ocorrer em diversos casos onde o SGBD falha em atualizações.

O script está publicado neste endereço, por tylerfontaine,: por https://github.com/tylerfontaine/zmcheckpointidtool

Após efetuar o download do script (que é executado com o usuário zimbra), primeiramente execute o mesmo sem parâmetros, para identificar em quais contas o que problema está ocorrendo:

$ zmcheckpointidtool

Para executar a correção em todas as contas afetadas, execute o comando com o parâmetro “-f”:

$ zmcheckpointidtool -f

Caso deseje executar a correção apenas em contas específicas, acrescente o “-m”, seguido pelo nome da conta:

$ zmcheckpointidtool -f -m user@domain.com

Zimbra: Comportamento de fallback das urls “ldap_url” e “ldap_master_url”

photo

Olá ! Nesse artigo gostaria de compartilhar com vocês um esclarecimento sobre o funcionamento de fallback das urls “ldap_url” e “ldap_master_url“.

Quando se utiliza múltiplos servidores ldap no Zimbra, essas diretrizes permitem o apontamento de múltiplos servidores ldap, para contingência. Desta forma, não é efetuado o balanceamento de carga, e sim quando um servidor fica indisponível , o Zimbra, automaticamente, direciona as conexões para o próximo da relação.

Porém, o comportamento quando um servidor que estava “marcado” como indisponível é restabelecido, não é direcionar novamente as conexões para o mesmo. Portanto, para que um servidor ldap, que apresentou indisponibilidade, passe a ser utilizado novamente, é necessário reiniciar os serviços.

Efetuei a abertura de uma solicitação de melhoria, pois acredito, na minha humilde opinião, que vale ao menos a análise da modificação desse comportamento. Caso concordem com essa requisição, por favor “votem” no bug aberto:

https://bugzilla.zimbra.com/show_bug.cgi?id=107550

Zimbra: Howto de instalação do Zimbra 8.7 (OSE) no Ubuntu 16

photo

Olá ! Para esse ano, irei dedicar alguns artigos sobre instalação e dicas básicas do Zimbra. Analisado o perfil das minhas publicações, constatei que os posts estavam exclusivamente relacionados a implementações de funcionalidades ou correção de problemas. Portanto, você que está começando com Zimbra, espero que este blog também consiga te ajudar.

Vamos então ao primeiro artigo: Instalação do Zimbra 8.7 (Open Source) no Ubuntu 16 !

Continuar lendo “Zimbra: Howto de instalação do Zimbra 8.7 (OSE) no Ubuntu 16”

Zimbra: Alerta de bug grave: Remoção dos pacotes do Zimbra (8.7.0 e 8.7.1) no Ubuntu

photodownload

Olá ! Nesse post gostaria de compartilhar com vocês um alerta crítico para quem possui as versões 8.7.0 e 8.7.1 instaladas no SO Ubuntu:

Foi identificado que ao efetuar atualizações do sistema operacional (14 e 16), pacotes essenciais do Zimbra estavam sendo removidos, tornando a aplicação indisponível. 

  • Até o momento, não há uma correção, portanto, não atualizem o SO e remova as atualizações automática do sistema, caso esteja configurado desta maneira.
Bug aberto para acompanhamento: https://bugzilla.zimbra.com/show_bug.cgi?id=107436

Zimbra: Solucionar erro “Problem parsing XML – The element type hr”

photo

Olá ! Nesse artigo gostaria de compartilhar a solução para o erro abaixo ao inicializar o Zimbra, especificamente o serviço mailbox:

misc – Problem parsing XML – Fatal Error: Problem on line 10 of document : The element type “hr” must be terminated by the matching end-tag </hr

Continuar lendo “Zimbra: Solucionar erro “Problem parsing XML – The element type hr””

Zimbra Network: Bug com 2FA (Autenticação de dois fatores) ao atualizar para a versão 8.7

photo422789_3f8a1934797d4200a0dd9fb2c6b61a34-mv2

Olá ! Esse artigo se aplica somente para quem possui a versão Network implementada. A versão 8.7, na edição Network, trouxe a autenticação de dois fatores (2FA) como uma das grandes novidades !

Em ambientes Multi-server, foi relatado um bug (erro de Javascript) ao habilitar este recurso antes de atualizar todos os servidores Mailbox. Portanto, caso você possua um cenário Multi-server com a edição Network e esteja atualizando para a versão 8.7, somente habilite o recurso 2FA após atualizar todos os seus servidores Mailbox.

Link do bug para mais informações e acompanhamento: 

https://bugzilla.zimbra.com/show_bug.cgi?id=105056